Expected FS format ‘2’; found format ‘4’

Wie ich schon in einem früheren Blog beschrieb, sind hier die Versionen vom Server und Client unterschiedlich.

Gute Artikel hierzu:

http://www.coderanch.com/t/106547/vc/Difference-between-subversion-subclipse

http://subversion.apache.org/docs/release-notes/1.6.html

Nach dem ich alle meine Clients (Tortoise und Subclipse) per Update auf den neuesten Stand gebracht habe, erhielt ich immernoch dieselbe Fehlermeldung.

Offensichtlich sind die Clients (noch) nicht mit dem erstellten Repository kompatible.
Nach einigen recherchen fand ich heraus das dem create Befehle einen Parameter für Abwärtskompatibilität mitgeben kann.

svnadmin create --pre-1.5-compatible d:/SVN/(projekt)

Hinterlasse eine Antwort

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *

Du kannst folgende HTML-Tags benutzen: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>